Фев 12

Те из вас, кто разрабатывает, дорабатывает и использует сценарии VMware PowerCLI , знает, что время от времени требуется использовать модуль какой-то конкретной версии, который идет в составе PowerCLI определенной версии. Это может быть из-за бага в новом пакете или несовместимости старых скриптов с новыми модулями. Если вы посмотрите на свойства пакета VMware PowerCLI на сайте PowerShell Gallery , то увидите соответствующие версии входящих в него модулей: Если вам нужно скачать нужный пакет из PowerShell Gallery, сделать это просто – там есть кнопка Manual Download: Но есть и возможность напрямую установить модуль из галереи, используя команду: Install-Module -Name VMware.PowerCLI Но это команда установит только последнюю версию модуля, а на блоге VMware появилась интересная функция Save-PowerCLI , которая позволяет указать в параметре -RequiredVersion нужную версию и скачать ее с последующей установкой: Собственно, сам исходник функции Save-PowerCLI:

Читать даль?е (источник):
Загрузка или установка нужной версии VMware PowerCLI из PowerShell Gallery.

Comments are closed.